Lolokai – Supervision, systèmes, réseaux, base de données…

12

Configuration d’un VPN IPSec entre deux routeurs Cisco

Said ASSOUMANI 27 mars 2012

Article écrit en collaboration avec Loïc FONTAINE

Introduction

Définition

VPN est l’acronyme de « Virtual Private Network » soit un réseau privé virtuel.

Par exemple, cela va nous permettre depuis notre domicile, d’avoir accès au réseau local d’un autre site distant (notre entreprise par exemple) à travers une connexion internet sécurisé (IpSec). On parle alos de VPN Remote-Access.

Le VPN va aussi nous permettre de relier deux sites, par exemple, une grande entreprise a deux locaux situés à deux endroits bien distinct, à l’instar des lignes dédiées où l’on devais passer par un opérateur ou encore au lieu de mettre en place des liens physique entre ces deux sites (fibre optique…) on va passer par internet pour relier ces deux sites. On parle alors de VPN Site-To-Site.

Ainsi, on aura accès aux ressources de notre entreprise (fichiers partagés, intranet, extranet…) comme si on y était.

Fonctionnement

VPN repose sur un protocole de tunnelisation (tunneling), le protocole va permettre aux données de passer d’une extrémité du VPN à l’autre de manière sécurisé en utilisant des algorithmes de cryptographie.

Dans notre exemple, nous allons utilisé le protocole IPSec qui est un framework regroupant plusieurs protocoles et qui permet de garantir la confidentialité, l’intégrité et l’authentification des échanges.

Configuration d’un VPN IPSec

Il faut savoir qu’il y a deux types de VPN :

  • Site-to-Site : Liaison entre deux sites distants
  • Remote-Access : Liaison entre une machine distance et un site

Informations

Quelques informations pour notre topologie :

  1. Nous allons utilisé le protocole : esp
  2. Pour la confidentialité nous utiliserons AES 128 bits
  3. Pour l’intégrité nous utiliserons le SHA-1
  4. Pour l’authentification nous utiliserons la clé pré-partagée
  5. Et nous utiliserons le group 2 pour Diffie-Helman

En ce qui concerne la clé pré partagée (Pre-shared key) on va mettre une clé commune sur les deux routeurs pour qu’ils puissent s’authentifier entre eux.
Diffie-Helman est un protocole qui va permettre l’échange de la clé de chiffrement de manière sécurisée (sans envoyer la clé explicitement sur le réseau).
Nous allons au tout au long de la configuration passer par deux phases principales : IKE Phase 1 et IKE phase 2.

Pour faire simple dans l’IKE de phase 1 nous allons configurer les politiques IKE (méthode de chiffrement, durée de vie, méthode d’intégrité) ce qui va permettre de définir une IKE Security Association.
Dans l’IKE de phase 2 nous allons configurer les politique de sécurité IPSec (protocole esp, vérifier le type de liaison) afin d’avoir un IPSec Security Association.

Les Routeurs doivent IMPERATIVEMENT avoir les mêmes politiques IKE et IPSec configurées.

Configuration d’un VPN Site-to-site

 

Nous allons configurer le VPN sur le routeur RouteurEntreprise afin de permettre l’établissement d’une liaison avec RouteurMaison.

Création d’un acl étendue permettant l’établissement d’un tunnel VPN

Ici nous allons autoriser l’établissement d’un tunnel IPSec entre les deux routeurs :

RouteurEntreprise(config)#ip access-list extended IPSECACL
RouteurEntreprise(config-ext-nacl)#permit ahp host 170.30.1.2 host 172.30.2.2
RouteurEntreprise(config-ext-nacl)#permit esp host 170.30.1.2 host 172.30.2.2
RouteurEntreprise(config-ext-nacl)#permit udp host 170.30.1.2 host 172.30.2.2 eq isakmp
RouteurEntreprise(config-ext-nacl)#exit

Création de notre politique IKE pour la phase 1

Nous définissons notre politique IKE.

RouteurEntreprise(config)#crypto isakmp policy 100
RouteurEntreprise(config-isakmp)#encryption aes 128
RouteurEntreprise(config-isakmp)#group 2
RouteurEntreprise(config-isakmp)#hash sha
RouteurEntreprise(config-isakmp)#lifetime 86400
RouteurEntreprise(config-isakmp)#exit

Création de clé pré-partagé

Nous définissons la clé pré-partagée : VpnK3! ainsi que l’adresse IP du routeur distant avec lequel on communique

RouteurEntreprise(config)#crypto isakmp key VpnK3! address 170.30.2.2

Création de notre politique IPSec pour la phase 2

Nous définissons notre transform-set pour l’établissement d’une liaison IPSec SA

RouteurEntreprise(config)#crypto ipsec transform-set IPSECSET esp-aes 128 esp-sha-hmac

Création de la crypto ACL

Nous créons la crypto ACL qui est une ACL qui va identifier le traffic « interessant » c’est à dire le traffic qui doit passer par le tunnel VPN (ici c’est le traffic depuis le LAN Entreprise vers le LAN Maison)

RouteurEntreprise(config)#ip access-list extended CRYPTOACL
RouteurEntreprise(config-ext-nacl)#permit ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255
RouteurEntreprise(config-ext-nacl)#exit

Création de la crypto MAP

Nous créons la crypto map qui définit le chemin qu’emprunte notre tunnel avec : la politique IPSec, la crypto ACL, le transform-set pour la politique IPSec et l’adresse IP du routeur distant avec lequel on veut communiquer.

RouteurEntreprise(config)#crypto map IPSECMAP 100 ipsec-isakmp
RouteurEntreprise(config-crypto-map)#set peer 170.30.2.2
RouteurEntreprise(config-crypto-map)#set transform-set IPSECSET
RouteurEntreprise(config-crypto-map)#match address CRYPTOACL
RouteurEntreprise(config-crypto-map)#exit

Application de notre crypto map et de l’acl pour autoriser le tunnel sur l’interface de sortie s0/0/0

On application la crypto-map et l’ACL qui autorise l’établissement du VPN.

RouteurEntreprise(config)#interface s0/0/0
RouteurEntreprise(config-if)#crypto map IPSECMAP
RouteurEntreprise(config-if)# ip access-group IPSECACL out
RouteurEntreprise(config-if)#exit

Configurer le RouteurMaison

La configuration est la même que pour Routeurentreprise à l’exception de :

  • Dans l’ACL IPSECACL on doit inverser l’adresse IP de l’hôte source et de l’hôte de destination
  • Dans la définition du transform-set on doit changer l’adresse du peer en mettant l’adresse IP de RouteurEntreprise
  • Dans l’ACL CRYPTOACL on doit inverser le réseau source et le réseau de destination
  • Dans la crypto map on doit mettre comme adresse du peer l’adresse IP de RouteurEntreprise

Conclusion:

Nous venons à travers de ce billet voir le principe d’un VPN et surtout comment configurer un VPN de type Site-to-site sur un équipement Cisco.

Que penser vous de ce billet ? Utilisez-vous du VPN dans le cadre de votre travail ou dans d’autres situation ? Vous est-il déjà arrivé de configurer un VPN ? Si oui, avec quels protocoles ?Said ASSOUMANI

Comments (12)

  1. Merci beaucoup pour cette explication.

    J’étais en train de chercher comment relier deux sites et j’avais prévu des modems/routeurs Cisco qui gèrent les tunnels VPN IPSec 50 et le protocole réseau IPSec.

    Ton article est bien clair, merci du partage de connaissance dans le world wide web !

    Répondre
  2. Je ne sais pas ce que je fait de mal. J’ai créer un petit réseau avec packet tracer avec 2 pc et 3 routeurs dont un des routeurs représente internet. Le pc 1 est connecter sur le routeur 1 sur l’interface fa0/0. Le routeur 1 est connecter sur le routeur 2 de l’interface fa0/1 vers l’interface fa0/0. Le routeur 2 est connecter au routeur 3 de l’interface fa0/1 vers l’interface fa0/1. Le routeur 3 est connecter sur le pc 2.

    PC 1 ip 172.16.1.1/24
    gw 172.16.1.254

    Routeur 2 ip (fa0/0) 172.16.1.254/24
    ip (fa0/1) 82.1.1.2/24
    route 0.0.0.0 0.0.0.0 82.1.1.1

    Routeur 2 ip (fa0/0) 82.1.1.1/24
    ip (fa0/1) 82.2.2.1/24
    route 172.16.1.0 255.255.255.0 82.1.1.2
    route 172.16.2.0 255.255.255.0 82.2.2.2

    Routeur 3 ip (fa0/1) 82.2.2.2/24
    ip (fa0/0) 172.16.2.254/24
    route 0.0.0.0 0.0.0.0 82.2.2.1

    PC 2 ip 172.16.2.1
    gw 172.16.2.254

    avant la procédure décrite mon pc 1 ping mon pc 2 sans problème mais une fois la procédure appliqué, le routeur 1 est capable de faire un ping vers l’adresse 172.16.2.254 mais pas vers 172.16.2.1. Le routeur 3 est capable de fair un pigne vers l’adresse 172.16.1.254 mais pas vers 172.16.1.1 et pour finir les pc ne peuvent pas faire de ping au dela de leur gateway. Est-ce que quelqu’un aurait une idée sur la cause du probème

    Répondre
  3. Bonjour, j’essaye mettre en place une connexion VPN sur cisco dans le cadre d’un projet, mais je bloque à partir de cette commande:
    « crypto isakmp policy 100″
    En effet, cette commande n’est pas reconnu sur mon routeur.

    J’ai Cisco Packet Tracer v5.3.3, que faut il que je fasse pour que cette commande fonctionne ?

    Merci d’avance.

    Répondre
  4. Bonjour

    Voila je travaille pour une entreprise et dans le cadre de l’optimisation des coûts de vpn .je voulais créer un VPN entre deux sites distants entreprise et usine .
    la question est la suivante :
    est ce que je peux configurer les deux routeur de la gamme 1800 de Cisco afin de créer la liaison VPN .
    .a l’occasion c’est un honneur et plaisir d’écrire sur votre page .

    Je vous remercie infiniment

    Répondre
  5. Bonjour,
    je voudrais savoir comment sont pris les adresse côté wan des deux routeur?
    si j’ai une adresse fixe publique et deux routeurs A et B distant peut-on créer des sous-réseaux avec cette adresse et les utiliser pour adresse les pour wan des routeur?
    Merci

    Répondre
    • Les adresses WAN des deux routeurs sont effectivement les adresses IP publiques. Ce sont des adresses IP qui entrent en jeu lors de l’établissement du tunnel.

      Répondre
  6. bonjour j’ai une question, le cas ou j’ai plusieurs routeurs (ex:500) pour configurer site-to-site prendra beaucoup de temps et une précision on configurons a chaque fois la même config,si on utilise les GETVPN c une bonne solution, merci

    Répondre

Laisser un commentaire

Login to your account

Can't remember your Password ?

Register for this site!